Tidal Lossless/High Resolution errors


  • Hello,
    First thank you for the great work on developing this application.
    I am running into a few issues when trying to play Tidal Lossless or High Resolution files.
    For certain tracks I receive "Could not determine type of stream." and for others "Your GStreamer installation is missing a plug-in.".

    I have installed all of the gstreamer plugins, I am also able to play local FLAC/WAV files without any issues.

    In the logs I can see the following errors:

    18:17:42.126 ERROR GstEngine:911                    "Stream discovery for http://<TIDAL FLAC URL>== failed: Some plugins are missing for full discovery"
    18:17:42.127 DEBUG AuddLyricsProvider:140           AudDLyrics: Got lyrics for "Radiohead" "Subterranean Homesick Alien"
    18:17:42.139 ERROR GstEnginePipeline:901            ErrorMessageReceived ID: 5 Domain: 3834 Code: 12 Error: "Your GStreamer installation is missing a plug-in."
    18:17:42.139 ERROR GstEnginePipeline:902            ErrorMessageReceived ID: 5 Domain: 3834 Code: 12 Debug: "../gst-plugins-base/gst/playback/gsturidecodebin.c(1024): no_more_pads_full (): /GstPlayBin:playbin-20/GstURIDecodeBin:uridecodebin4:\nno suitable plugins found:\n../gst-plugins-base/gst/playback/gstdecodebin2.c(4719): gst_decode_bin_expose (): /GstPlayBin:playbin-20/GstURIDecodeBin:uridecodebin4/GstDecodeBin:decodebin7:\nno suitable plugins found:\nMissing decoder: text/x-matlab (text/x-matlab)\n"
    18:17:42.142 ERROR GstEnginePipeline:901            ErrorMessageReceived ID: 5 Domain: 3833 Code: 1 Error: "Internal data stream error."
    18:17:42.142 ERROR GstEnginePipeline:902            ErrorMessageReceived ID: 5 Domain: 3833 Code: 1 Debug: "../gstreamer/libs/gst/base/gstbasesrc.c(3127): gst_base_src_loop (): /GstPlayBin:playbin-20/GstURIDecodeBin:uridecodebin4/GstSoupHTTPSrc:source:\nstreaming stopped, reason not-linked (-1)"
    18:17:42.144 ERROR GstEngine:563                    GStreamer error: 3834 12 "Your GStreamer installation is missing a plug-in."
    

    Does anyone have any ideas on how to solve this issue?

    I am on Arch Linux, in Windows I can play using the Tidal app without any issues.

    Thanks


  • @Hompacko said in Tidal Lossless/High Resolution errors:

    Missing decoder: text/x-matlab (text/x-matlab)

    The stream urls return text data instead of FLAC stream here, possible MPEG DASH or something. So you need to find another client ID / token that returns unencrypted streams.


  • @jonas would you know which is the current working method? I tried https://github.com/lucaslg26/TidalAPI#obtaining-a-token-from-tidal-for-windows but as you can see it doesn't seem to be working. I also tried the Android "okhttp" method, but I cannot find that folder anywhere(com.aspiro.tidal/cache/okhttp).



  • @jonas yes I tried that, it is the "okhttp" method I mentioned in my previous post. I'm wondering if we need to use a specific app version or have to use an actual stock android device.


  • I was finally able to get it to work, I used the /e/Foundations version of LineageOS and was able to find the "okhttp" folder, afterwards I found the token. Tidal was installed via microG.

    Thank you for your help


  • Hey @Hompacko I'm having the same issue. I don't have any Android device, could you help me please? I have the same problem only with lossless and hifi


  • You don't need a android phone, you can just download a apk android file and extract it.


  • @jonas is there any tutorial for this?


  • Another alternative would be to use an Android emulator and install Tidal on it, then just follow the steps from the posted link. If you are on Linux you can try anbox or android-x86


  • @Hompacko Thanks