• Updates after v 0.6.9 seem to have problems with very large collection of (FLAC with cue files) i.e; very much longer to update collection DB and errors in track listings. V 0.6.9. handles collection perfectly, but subsequent versions both Windows and Suse linux, have this problem.


  • What tags are incorrect?
    How long does it take?


  • I can't see any changes done after 0.6.9 that should cause the collection update to be slower.
    But I did some changes to the cueparser after version 0.6.9. I can't see anything wrong there and it works here. But I only have a few albums on cue for testing.
    Can you send me some non working files I can test with?


  • @jonas
    V 0.6.13 works perfectly with small number of flac files but with my large collection (about 1000) it takes about an hour to load the DB (as opposed to about 10-15 mins with V 09). Furthermore, when collection is finally registered, some of the first tracks are not listed. I tried the same with opensuse Leap 15.2 with exactly thesame problem. This is not a problem for me since V 0.6.9 is an excellent app. and works perfectly so I have reinstalled it on Win10 computer, but it might be a problem for others who try the recent version and have big collections with cue files, and I don’t think 0.6.9 is still listed for OpenSuse Leap 15.2.


  • I've compared the source code changes between 0.6.9 and 0.6.10, there aren't any changes that should lead to something like this, in fact there aren't any changes at all to the collection watcher(scanner) at all. I did a small change to the cue parser but if that created a bug it would be related to missing tags, nothing more.
    I have 24500 songs and it finishes in under 10 minutes on a slow SSD that is pretty full so the speed is reduced.
    HDD's have caching so the second time you scan it will probably be much faster, but 1 hour sounds much too long with just 1000 files. Is it SSD, hybrid or mechanical drive? . Are you experiencing the same thing with different HDD's, or is it the same HDD on different computers? Is it a network drive?


  • @jonas Files
    The files (large number of FLACs with cue files, plus a few MP3s in a separate directory) are on an external Samsung USB SSD which is used for all comparisons and tested on two Win 10 computers with identical results: V 0.6.9 loads quickly and works flawlessly, Versions 0.6.11 and 13 take an age to register in DB and miss tracks when a piece is added to the playlist . Each time I remove collection folder then add again to reload collection. All mysterious. Same result with OpenSuse Leap 15.2 with version 0.6.13, but I cannot test with version 0.6.9 since it does not seem to be available for this OS.


  • @jonas
    I have justed tested recent V7.0 with Win 10. It still takes longeer than 6.0.9 to update DB but all tracks are now present and it now works fine. It seems a bit less responsive than V.609 when selecting pieces and tracks but this is not a real problem. I tried with OpenSuse Leap 15.2 but cannot get it to install with Discover (repo not available) or Yast. Zypper installs it but the previous (V.0.13) version which has the original problem of cutting tracks. Perhaps it is because I have mainly FLACs which average about eight tracks, so the total is very large.