• A little late, but thanks for your answer about fading. That is obvious. So no resampling. New question about Low Latency kernel Ubuntu Studio in which I am using Strawberry now. Is this kernel only for recording or also useful in audio playback? What is the best setting for the buffer? Thanks.

  • @Ton Answer my own question about low latency. It was difficult to find because most of the internet is about recording. Not about playback.

    I liked this explanation. https://medium.com/@juliozynger/your-app-and-low-laatcy-audio-output-d21d7b672305 and this one https://juce.com/ I will get there step by step. I think.

  • @jonas Thanks for: Removed use of deprecated gstreamer "low-percent" (Minimum buffer fill setting) and Added buffer low and high watermark settings to backend settings.
    But how do I know the best settings for my desktop? Is that the installation setting that comes with the hardware or is that an average? I am using Ubuntu Studio.

  • You should not change the watermark settings unless you have a problem.
    And if you have problems it is usually the buffer duration you should increase anyway.
    The low-watermark is the equivalent to low-percent except it's a double value instead of percent like before.
    Explained here: https://gstreamer.freedesktop.org/documentation/additional/design/buffering.html?gi-language=c

  • Thank you Jonas for your clear answer. I will not touch the low watermark settings. It all works fine. I am interested in the best possible adjustment of Strawberry for the best possible sound reproduction. Another general question about that. Does a low-latency kernel contribute to better sound reproduction for music players? Or is it only important for music studio production? I read that you have back pain. Hopefully you will be better and you will have less pain and can sleep!

  • Not that I know of, I think it's more to make playback smooth without interference and to keep audio & video in sync.
    I used to compile a custom low-latency kernel for many years, otherwise I had "hiccups" in the sound. I used to set CONFIG_PREEMPT_RCU to yes and CONFIG_HZ_1000 to yes.
    I've used openSUSE since it was SUSE Linux, and I remember they had a desktop kernel for many years which I think did the same thing. I don't know how the kernels in different distros are configured.
    I'm not an expert on it, I think it's better that you ask in a linux forum, or kernel related mailinglist.

  • @Ton I moved the messages here.