I get stutter/jump when starting flac files.



  • Every time I start or change song, I get this short jump around 1 second mark.
    E.g. Queen "I Want It All" starts with "I want all"

    I don't have such problem with clementine or foobar2k.



  • What OS is this?
    Do you know how to compile from source? Instructions can be found in the WIKI: https://github.com/strawberrymusicplayer/strawberry/wiki
    Try commenting out / removing this line in src/engine/gstenginepipeline.cpp:

    discoverer_ = gst_discoverer_new(kDiscoveryTimeoutS * GST_SECOND, nullptr);
    


  • This is on Windows 10.

    I'm afraid I don't have extra time right now to setup build environment for windows. I can possibly try later when I have extra hour or two to spare.

    Do you have working windows ci pipeline that could build binary for testing from such commit?





  • I'm only guessing that it has to do with the stream discoverer since you said it works with Clementine, if you still have the problem with that setup we can rule it out completely.
    I can't reproduce the problem at all, even on Windows.



  • Ok, tried that one and problem persists.



  • I'm also observing this problem on multiple installations (W10). Seems only on FLAC. Directsound and wrapper both seem affected.
    Anything I can do to assist troubleshooting Jonas?



  • Can you try the latest build from here https://builds.strawberrymusicplayer.org/windows/, (currently StrawberrySetup-0.7.2.211.g22bfbab8-x64.exe). Select "Stream audio to WASAPI" in backend / output.



  • Does it occur only when starting playback, or does it occur when it automatically plays the next track too?



  • To check whether the problem is in Strawberry or GStreamer / the system itself, you can use a command line utility called gst-launch-1.0.

    Download and install https://gstreamer.freedesktop.org/data/pkg/windows/1.18.0/mingw/gstreamer-1.0-mingw-x86_64-1.18.0.msi

    Open Command Prompt.
    Then run:

    cd \
    cd gstreamer\1.0\mingw_x86_64\bin
    

    Test a local FLAC file:

    gst-launch-1.0 filesrc location=c:/music/flacfile.flac ! decodebin ! audioconvert ! directsoundsink
    

    (Use / instead of \ in paths).

    Test a stream:

    gst-launch-1.0 souphttpsrc location=https://stream.radioparadise.com/mellow-320 ! decodebin ! audioconvert ! audioresample ! directsoundsink
    


  • @jonas it occurs every time, regardless if I start playback manually or if it plays next automatically.

    There's been some changes since last time I tried (I think it was 0.7.2-55). Back then stuttering happened around 1 second mark, now (0.7.2-211) it happens almost immediately and is less noticable.



  • and no problems with

    .\gst-launch-1.0 filesrc location='Z:/music/Queen.Discography.Flac/Queen - Greatest Hits II (1991) [FLAC]/03 - Radio Ga Ga.flac' ! decodebin ! audioconvert ! directsoundsink
    


  • Played around with settings:
    Wrapper audio sink for automatically detected audio sink
    -> small stutter
    Output to a sound card via Direct Sound
    -> no stutter (actually, I think there might be a really small stutter but ~3 seconds after start)
    Stream audio to an audio capture device through WASAPI
    -> small stutter



  • Strangely I can't reproduce this on 2 different Windows 10 laptops tested with different soundcards and DAC's.
    Can you see any spikes in CPU usage in task manager when this happens. Do you got anti-virus software, other audio software or other software installed that could possible interfere?



  • No spikes in CPU usage, and no other software interfering that I could think of. I get same problems if I use either of my audio solutions (headphones + xonar essence st soundcard or hdmi to external amp)

    If I use "direct sound" -setting it's very hard to notice, but there is small skip or stutter with flacs (around 3 second mark when average bitrate is still going up). I can't hear it clearly with all songs, but they definitely sound wrong (few millisecond skip, hard to estimate)

    There's also short pause after pressing "Play" after "Pause".



  • It seems that I got less problems when I tried to record it, but two examples can be heard at around 16 and 28 second marks: https://katiska.dy.fi/temp/music/Strawberry Music Player 2020-10-05 23-46-23.mp4



  • Hi, I wanted to report that I'm having the same problem not only with FLAC files but also with MP3s in 0.8.2. I'm using 64-bits Windows 10 and the two other media players I have available (Firefox and VLC) plus the gst-launch command mentioned above don't show any stuttering.

    If I remember correctly, an install of 0.7.2 on the same computer and OS showed the same thing when playing music via the Tidal option built in (the only feature I tried then).



  • @cripy I think that is a different issue. Try increasing the buffer duration to 6000 or 8000 ms.



  • @warbaque
    A few things to try:

    1. Try setting the buffer duration to 0, it should disable the buffering entirely and the watermark settings won't be used.
    2. Increase the process priority. Open task manager, right click on strawberry and select "Set priority" and "High"


  • @jonas Problem persists 😞



  • It's happening to me too. It happens on mp3, flac and m4a aac on GStreamer while listening through bluetooth (AAC & SBC). I am running the latest git version built from source on 13th Nov.

    Operating System: Manjaro Linux KDE
    KDE Plasma Version: 5.20.2
    KDE Frameworks Version: 5.75.0
    Qt Version: 5.15.1
    Kernel Version: 5.9.3-1-MANJARO
    Backend: Gstreamer 1.18.1-1

    it's definitely a problem with Gstreamer because switching to vlc fixes the issue.


Log in to reply