Playing Audio CDs - No "play Audio CD" command on "Music" menu


  • Hi there!

    As said in the topic title, my Strawberry installation does not have a "play audio CD" command in the "music" menu and I don't find any way to make Strawberry play CDAs.

    Don't know if I am missing something obvious, but not avail so far. I'm new to Strawberry.

    I'm using the Spanish translation, Strawberry 0.6.12, on Windows.

    Any help or clue will be appreciated!!!

    Thanks!!

    Pablo


  • CD support is currently broken on Windows so I disabled it in the menu.


  • Thanks @jonas !!!!

    Good to know (perhaps to make it clear that, as known issue, somewhere in the documentation? perhaps it is and I missed, sorry in that case).

    Are there plans to fix that in coming releases?

    Cheers!!!

    Pablo


  • We don't really have much documentation, but I guess it should be noted in the feature list.
    I have looked into it but didn't immediately figure it out. I don't know when I get a chance to look into it again. It's bit more work as I need to set up a build environment on Windows to debug it. I do the development on Linux, and most things just work on Windows because most of the code is the same. However there are a few minor gstreamer related issues on Windows that probably would be best to look into at the same time. Setting up a small program to reproduce and debug this instead of compiling the entire program on Windows would probably be easier.

    • CD playback does not work
    • The stream discoverer does not work
    • The WASAPI plugin is causing crashes