What version is this? Version 1.0.15 is always using strict ssl and no option to turn it off. Fixed in 1.0.16.
It could be related to the SSL certificate, do you have the option for "Use strict SSL mode" in the backend settings, turn it off.
It could also be that you are missing a gstreamer plugin for the stream, or the stream is unsupported.
You can use the gst-discoverer-1.0 utility to figure out what stream it is.
Usage.: gst-discoverer-1.0 <URL>
Then install the specific gstreamer plugin needed.